Maven 3.x在执行install命令的时候无法调用yuicompressor-maven-plugin

Maven的yuicompressor-maven-plugin插件用来压缩、合并js或css文件,最近将Maven由2.x升级到3.0.x,发现执行install命令之后不执行yuicompressor-maven-plugin插件了,后来找到了原因是因为3.0.x开始默认的phase任务单元不是原来的pre-package,需要手动指定,配置信息如下:
net.alchim31.maven
yuicompressor-maven-plugin
1.3.0


prepare-package
compress


参考资料:
How to get maven to build a war with minified files using yuicompressor-maven-plugin
使用YUI Compressor Maven插件压缩 js,css 输出war包

发表评论

电子邮件地址不会被公开。 必填项已用*标注